老梗了,时代一直在发展,安装也更简洁了

elasticsearch 用的是 2.3.3 的版本
java是1.8
ik 是1.9.3的版本

安装跟以前不太一样了:

elasticsearch安装:

wget  https://download.elastic.co/elasticsearch/release/org/elasticsearch/distribution/tar/elasticsearch/2.3.3/elasticsearch-2.3.3.tar.gz

vi elasticsearch-2.3.3/config/elasticsearch.yml  
...
network.host: 172.16.11.2,127.0.0.1  
http.port: 9200  
...

cd elasticsearch-2.3.3/bin  
./elasticsearch -Des.insecure.allow.root=true -d

装ik: 直接编译ik 1.9.3的版本,得到一个zip包,把包解压到elasticsearch的plugin/ik下就完成了,什么都不用改,就ok了

下载:elasticsearch-analysis-ik-1.9.3.zip

注意,上面的ik 1.9.3是用java 1.8编译出来的

然后:

mkdir -p elasticsearch-2.3.3/plugins/ik  
unzip -x elasticsearch-analysis-ik-1.9.3.zip -d elasticsearch-2.3.3/plugins/ik  

就OK了啊,elasticsearch.yml 不做任何修改!!!

然后测试一下,用浏览器访问下面这个地址:

http://172.16.11.2:9200/_analyze?analyzer=ik&pretty=true&text=我爱北京天安门  

这样就好了

comments powered by Disqus